click to home page Travel light... WALK EASY INC.
Navigation menu      
ResellInteractLearnShopResell linkInteract linkLearn linkShop link
Home > Browser Requirements
  Copyright Notice
  Terms of Sale
  Privacy Policy
  Shipping Options
 
Browser Requirements

This site is designed for use with the latest versions of Internet Explorer and Netscape Navigator. If you use older versions (including Explorer 3.0, Navigator 3.0 or AOL 3.0 or earlier), you will experience technical difficulties with online ordering. You must also have JavaScript enabled in your browser's preferences.

To purchase products online at Walk Easy, you must use a browser that is SSL-compliant and has a "secure mode." This safeguards your personal data while you shop (look for a closed lock or an unbroken key at the bottom of the pages when completing your order.)

If you access our site with an older browser, functions such as online ordering, registration and the crutch evaluator may not work properly. We recommend downloading the latest version of your preferred browser to fully experience our site. We've added links to Internet Explorer and Netscape Navigator below - click on either to download the latest versions from here.

 

If you have problems accessing any part of our site, call us at 1-800-441-2904.

 
Netscape and Netscape Navigator are trademarks of Netscape Communications Corporation. Microsoft and Microsoft Internet Explorer are trademarks of Microsoft Corporation. AOL is a trademark of America Online, Inc.
Help | Contact Us | Privacy Policy | Browser Requirements
© Copyright 1997 - 2017, Walk Easy Inc.  All rights reserved.